Skip navigation links

MySQL Forums :: MySQL Workbench :: Workbench Not Loading my.ini on Windows XP


Advanced Search

Workbench Not Loading my.ini on Windows XP
Posted by: Allen McGruder ()
Date: January 22, 2010 09:26AM

I've installed MySQL 5.1 on a dedicated XP computer. To make things easier, I installed the server in the root at "C:\@MySQL" and pointed the data to the folder "C:\@MySqlData." I made these choices during installation and the server is running well. I then installed the MySQL workbench and created an admin connection to my server, which was easy enough.

However, I notice that the admin connection is not loading the correct config file located in "C:\@MySQL\my.ini." It's trying to load a "phantom" config file from a directory that doesn't exist: "%ProgramFiles%\MySQL\MySQL Server 5.1\my.ini." I didn't install to that directory. There is no "MySQL Server 5.1" in my "Program Files" folder.

The following is a quote from the workbench output window after connecting to the server:

read_mysql_cfg_file failed. Added empty content %ProgramFiles%\MySQL\MySQL Server 5.1\my.ini
Parsing options only from section mysqld

How can I point the workbench admin gui to the correct config file?

Thanks,
a

Options: ReplyQuote


Subject Views Written By Posted
Workbench Not Loading my.ini on Windows XP 5011 Allen McGruder 01/22/2010 09:26AM
Re: Workbench Not Loading my.ini on Windows XP 2198 Mike Lischke 01/25/2010 02:38AM
Re: Workbench Not Loading my.ini on Windows XP 1762 Randy McElveen 01/27/2010 11:26AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.