Skip navigation links

MySQL Forums :: GIS :: MySql version


Advanced Search

Re: MySql version
Posted by: Mike McCutcheon ()
Date: November 08, 2009 03:20AM

Actually, it's not so clear ....

Does anyone know where I can find a list of which GIS functions can be used with MySql 4.1.15-standard-log accessed via PHP's MySql 5.0.41 client API ?

NB Presumably the governing factor is the MySql 4.1.15-standard-log, not PHP's MySql API v5.0.41 ?

For MySql 4.1.15, the relevant online manual is the "MySQL 3.23/4.0/4.1 Manual". This manual points out that "Currently, MySQL does not implement all these GIS functions according to the specification. Those that are implemented return the same result as the corresponding MBR-based functions. Only Distance() and Related() work fully".

Then on January 29 2008, Lenz Grimmer kindly posted a comment to the online manual saying, "Some of the other functions mentioned above have now been implemented using non-MBR geometry."

However, as the manual covers versions 3.23 to 4.1, I can't work out which comments apply to my v4.1.15.

Options: ReplyQuote


Subject Views Written By Posted
MySql version 5150 Mike McCutcheon 11/06/2009 11:37AM
Re: MySql version 1992 Barry Galbraith 11/06/2009 03:25PM
Re: MySql version 1957 Mike McCutcheon 11/08/2009 02:32AM
Re: MySql version 1909 Mike McCutcheon 11/08/2009 03:20AM
Re: MySql version 1983 Barry Galbraith 11/08/2009 03:47AM
Re: MySql version 1978 Mike McCutcheon 11/08/2009 07:16AM
Re: MySql version for GIS functions 2006 Mike McCutcheon 11/09/2009 03:09PM
Re: MySql version for GIS functions 1946 Barry Galbraith 11/09/2009 05:52PM
Re: MySql version for GIS functions 1584 Mike McCutcheon 11/19/2009 10:52AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.