Skip navigation links

MySQL Forums :: Cluster :: API Not Connected


Advanced Search

API Not Connected
Posted by: R M ()
Date: July 15, 2012 09:28AM

Hello Cluster Group:

Im a DBA for many years but Im new to MySQL clustering. Using the Quick Start Guide for Linux I was able to setup a MySQL cluster with 2 datanodes, 1 mgmt node, and 1 SQL API node as follows on a single CentOS for testing purposes:

ndb_mgm> show
Connected to Management Server at: localhost:1186
Cluster Configuration
---------------------
[ndbd(NDB)] 2 node(s)
id=3 @127.0.0.1 (mysql-5.5.22 ndb-7.2.6, Nodegroup: 0, Master)
id=4 @127.0.0.1 (mysql-5.5.22 ndb-7.2.6, Nodegroup: 0)

[ndb_mgmd(MGM)] 1 node(s)
id=1 @127.0.0.1 (mysql-5.5.22 ndb-7.2.6)

[mysqld(API)] 1 node(s)
id=50 (not connected, accepting connect from any host)

ndb_mgm>

My question is why does the API say "not connected"? Ive read many forum posts already but they are not giving a straight answer. One post saids restart the entire cluster - I tried it and that didnt work, the API still has status "not connected". Can someone please explain what the problem is and how to fix it. Note, Im cluster newbie and trying to get up to speed quickly. Thank you for your help and time.

Options: ReplyQuote


Subject Views Written By Posted
API Not Connected 1598 R M 07/15/2012 09:28AM
Re: API Not Connected 872 R M 07/15/2012 09:55AM
Re: API Not Connected 1175 R M 07/15/2012 10:28AM
Re: API Not Connected 764 Ted Wennmark 07/23/2012 07:26AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.