Skip navigation links

MySQL Forums :: Cluster :: Getting Fatal Error when setting ndb_cluster_connection_pool


Advanced Search

Getting Fatal Error when setting ndb_cluster_connection_pool
Posted by: Stalin Subbiah ()
Date: October 06, 2012 03:31PM

Hi Everyone,

Anybody have seen this error before in setting ndb_cluster_connection_pool to a non-default value. I tried 4, 6, 8 but all gave same error.

Interesting thing is, we have 2 mysqld nodes and when i apply this change via mcm, both node gets the change, one node gets running state and 2nd node goes to failed state with this error in the log.

121006 15:14:20 [ERROR] /opt/app/mysql-cluster-advanced-7.2.7-linux2.6-x86_64/bin/mysqld: Incorrect information in file: './mysql/host.frm'
121006 15:14:20 [ERROR] Fatal error: Can't open and lock privilege tables: Got error 157 'Unknown error code' from NDBCLUSTER

Setting the value back to default, gets mysqld running again.

As you can see, i'm running 7.2.7 on Linux 5.8.

Thanks,
Stalin

Thanks,
Stalin

Options: ReplyQuote


Subject Views Written By Posted
Getting Fatal Error when setting ndb_cluster_connection_pool 1757 Stalin Subbiah 10/06/2012 03:31PM
Re: Getting Fatal Error when setting ndb_cluster_connection_pool 702 Stalin Subbiah 10/08/2012 05:10PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.