Skip navigation links

MySQL Forums :: Replication :: Replication began to work not always, not right away


Advanced Search

Replication began to work not always, not right away
Posted by: Dan Mor ()
Date: March 31, 2012 02:47PM

Hello!

I have strange bug, or I just do not understand all must be setted.

I have MASTER version '5.5.21-log'
and SLAVE version '5.5.21'

Replication all is done such as in all tutorials. All seems to be working - SLAVE always update its binlog position, observing the master, no error happens, after I set "slave-skip-errors=1062,1146"

but when I do some UPDATE-queries on MASTER, SLAVE renew the log-position, nut DO NOT make changes to database field values!!

And when some time passed (some hours), changes began appear, when new changes are done on master - so new logs began to process correctly. BUT those first changes that I make after replication was started - they still not appear in SLAVE database, so databases of SLAVE & MASTER come to be not synchronized!

I was tested it both in MYISAM and InnoDB tables. Effect is the same.

Why that start lag appears, can anybody explain me please?

Options: ReplyQuote


Subject Views Written By Posted
Replication began to work not always, not right away 995 Dan Mor 03/31/2012 02:47PM
Re: Replication began to work not always, not right away 476 Rick James 04/01/2012 05:37AM
Re: Replication began to work not always, not right away 588 Dan Mor 04/02/2012 12:47PM
Re: Replication began to work not always, not right away 452 Rick James 04/03/2012 08:58AM
Re: Replication began to work not always, not right away 449 Dan Mor 04/04/2012 02:26PM
Re: Replication began to work not always, not right away 441 Rick James 04/05/2012 07:36PM
Re: Replication began to work not always, not right away 500 Dan Mor 04/06/2012 07:33PM
Re: Replication began to work not always, not right away 441 Rick James 04/07/2012 03:57PM
Re: Replication began to work not always, not right away 716 Dan Mor 04/07/2012 08:08PM
Re: Replication began to work not always, not right away 436 Rick James 04/08/2012 03:41PM
Re: Replication began to work not always, not right away 524 Dan Mor 04/14/2012 11:14AM
Re: Replication began to work not always, not right away 422 Rick James 04/15/2012 11:47PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.