Skip navigation links

MySQL Forums :: Connector/JDBC and Java :: Å, Ä and Ö not working for me.


Advanced Search

Å, Ä and Ö not working for me.
Posted by: Pär Strindevall ()
Date: December 03, 2012 08:42AM

Hello!

I am using your Connector/J with JDBC in Java to create and populate a
database. However, the database contains Swedish characters (Å, Ä and Ö). I am able to create tables and insert data with Swedish characters via PHPMyAdmin and such, but via JDBC the characters appear as A? or O?. I have tried to connect to the
server with encoding in the URL such as:

?useUnicode=true&characterEncoding=ISO-8859-1

However, this did not work. I have read that the default encoding should
be able to handle the Scandinavian characters anyways so I'm guessing
changeing the encoding was futile to begin with. I did try UTF-8 as well
but without success.

What should I do? I've approached the issue iteratively and concluded
that the connector is the problem. Is there a way to maintain the
encoding all the way from the application to the database via the
connector?

Options: ReplyQuote


Subject Written By Posted
Å, Ä and Ö not working for me. Pär Strindevall 12/03/2012 08:42AM
Re: Å, Ä and Ö not working for me. Mark Matthews 12/03/2012 10:32AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.