Skip navigation links

MySQL Forums :: Connector/Python :: mysql-python 1.2.4 has hardcoded dependency on distribute 0.6.28


Advanced Search

mysql-python 1.2.4 has hardcoded dependency on distribute 0.6.28
Posted by: Katherine Elliott ()
Date: November 08, 2013 03:52PM

We are trying to use an internal PyPi server so we can be fully self-contained and not have to go through our proxy to connect to the global server. However, we've found that mysql-python 1.2.4 has a hardcoded distribute version and URL to the global PyPi server in distribute_setup.py. This is forcing us to continue to use our proxies to be able to connect to the global server to pull in distribute 0.6.28 when we install 1.2.4 from our local PyPi server.

From MySQL-python-1.2.4/distribute_setup.py, lines 49 and 50:

DEFAULT_VERSION = "0.6.28"
DEFAULT_URL = "http://pypi.python.org/packages/source/d/distribute/";

I don't see this requirement in 1.2.3.

What gives?

Options: ReplyQuote


Subject Written By Posted
mysql-python 1.2.4 has hardcoded dependency on distribute 0.6.28 Katherine Elliott 11/08/2013 03:52PM
Re: mysql-python 1.2.4 has hardcoded dependency on distribute 0.6.28 Geert Vanderkelen 11/27/2013 12:55AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.