Skip navigation links

MySQL Forums :: Perl :: DBD bootstrap parameter problem


Advanced Search

DBD bootstrap parameter problem
Posted by: Bertrand Rastello ()
Date: March 26, 2008 05:10AM

Hi all !

I have a problem since I have installed son my Solaris 10 system the file "mysql-standard-4.1.22-sun-solaris2.10-sparc-64bit.pkg.gz"
(I have desinstalled it).
When I compile my Perl program , it shows me :

install_driver(mysql) failed: DBD::mysql object version 4.005 does not match boo
tstrap parameter 4.004 at /opt/csw/lib/perl/5.8.8/DynaLoader.pm line 253.
Compilation failed in require at (eval 3) line 3.

Perl -V command is :

Summary of my perl5 (revision 5 version 8 subversion 8) configuration:
Platform:
osname=solaris, osvers=2.8, archname=sun4-solaris-thread-multi
uname='sunos ra 5.8 generic_117350-46 sun4u sparc sunw,sun-blade-1000'
config_args=''
hint=recommended, useposix=true, d_sigaction=define
usethreads=define use5005threads=undef useithreads=define usemultiplicity=de
fine
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='cc', ccflags ='-D_REENTRANT -xO3 -xarch=v8 -xspace -xildoff -I/opt/csw/b
db44/include -I/opt/csw/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
optimize='-xO3 -xarch=v8 -xspace -xildoff',
cppflags='-D_REENTRANT -xO3 -xarch=v8 -xspace -xildoff -I/opt/csw/bdb44/incl
ude -I/opt/csw/include'
ccversion='Sun C 5.8 Patch 121015-04 2007/01/10', gccversion='', gccosandver
s=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize
=8
alignbytes=8, prototype=define
Linker and Libraries:
ld='cc', ldflags ='-xarch=v8 -L/opt/csw/bdb44/lib -L/opt/csw/lib -L/usr/lib
-L/usr/ccs/lib -L/opt/SUNWspro/prod/lib/v8plus -L/opt/SUNWspro/prod/lib -L/lib'
libpth=/usr/lib /usr/ccs/lib /opt/SUNWspro/prod/lib/v8plus /opt/SUNWspro/pro
d/lib /lib /opt/csw/lib
libs=-lsocket -lnsl -lgdbm -ldb-4.4 -ldl -lm -lpthread -lc
perllibs=-lsocket -lnsl -ldb-4.4 -ldl -lm -lpthread -lc
libc=/lib/libc.so, so=so, useshrplib=true, libperl=libperl.so.5.8.8
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-R /opt/csw/lib'
cccdlflags='-KPIC', lddlflags='-G -L/opt/csw/bdb44/lib -L/opt/csw/lib -L/usr
/lib -L/usr/ccs/lib -L/opt/SUNWspro/prod/lib/v8plus -L/opt/SUNWspro/prod/lib -L/
lib'


Characteristics of this binary (from libperl):
Compile-time options: MULTIPLICITY PERL_IMPLICIT_CONTEXT
PERL_MALLOC_WRAP USE_ITHREADS USE_LARGE_FILES
USE_PERLIO USE_REENTRANT_API USE_SITECUSTOMIZE
Built under solaris
Compiled at Mar 16 2007 12:04:23
@INC:
/opt/csw/lib/perl/5.8.8
/opt/csw/share/perl/5.8.8
/opt/csw/lib/perl/site_perl
/opt/csw/share/perl/site_perl
/opt/csw/share/perl/site_perl
/opt/csw/lib/perl/csw
/opt/csw/share/perl/csw
/opt/csw/share/perl/csw

I'm completely sad, I work on this problem since 2 days..

I try lot of things, reinstall 32 bit version of Perl (mysql-5.0.51a-solaris10-sparc.pkg.gz) but nothing works fine... :((

I found two links on this problem :
http://www.issociate.de/board/post/411203/DBD-mysql-4.001.html
and
http://woss.name/2006/05/21/installing-dbimysql-on-solaris-10/

But I don't know what I must do, if i must install DBD-mysql-4.006 package, DBI-1.604 package...


Thanks a lot for your help and sorry for my poor english ! ;)

Bye

Bertrand

Options: ReplyQuote


Subject Written By Posted
DBD bootstrap parameter problem Bertrand Rastello 03/26/2008 05:10AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.