Skip navigation links

MySQL Forums :: PHP :: Server vs. Client version mismatch


Advanced Search

Re: Server vs. Client version mismatch
Posted by: Michael Erb ()
Date: February 11, 2008 01:30PM

In a similar vein, my web host apparently has a combination of MySQL server versions on it's various database servers. So some of my databases generate this warning message while others do not. when I asked my web host about the inconsistent versions and why they couldn't bring all servers to the same version, they replied...

"The problem from our end is that we cannot specifically correct it in the
way you specify. This is because PHP could only be compiled with a single
library version at a time. There is no way to have it compiled in
conjunction with every MySQL library version at the same time.

While we cannot say with 100% certainty that there will never be a problem
with a different library version, it has really been this way in our system
for quite a while (most likely several years at least) and we have never
observed any problems resulting.

In case you may be interested, to get this error to disappear from the
phpMyAdmin you can simply comment out section of code (lines 391-397 to be
exact) called 'strMysqlLibDiffersServerVersion' from the file named
main.php."

The bottom line is that closing my eyes to the problem, as they suggest, is not a solution. I am greatly concerened about the integrity of my database when editing in phpMyAdmin and therefore this error worries me.

Can anyone provide some guidance in this matter please?

Options: ReplyQuote


Subject Written By Posted
Server vs. Client version mismatch Don Pavlish 01/05/2008 08:38AM
Re: Server vs. Client version mismatch Michael Erb 02/11/2008 01:30PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.