Skip navigation links

MySQL Forums :: PHP :: Windows: problem with unicode after update


Advanced Search

Windows: problem with unicode after update
Posted by: Mark Stam ()
Date: December 15, 2013 04:18AM

I have a very strange problem. Several years ago I built a php program which can add and edit database records. In the MySQL database there are several records with unicode characters (people names like Wägner and Bergér). After a Windows update last week, my php program doesn't show the records with the unicode characters anymore. All records with ascii characters are shown perfectly, but all records with unicode characters are missing on the php page (just blank spots, the whole record is missing, not only the unicode characters).

This is my MySQL version:

+-------------------------+------------------------------+
| Variable_name | Value |
+-------------------------+------------------------------+
| protocol_version | 10 |
| version | 5.1.42-community |
| version_comment | MySQL Community Server (GPL) |
| version_compile_machine | unknown |
| version_compile_os | Win64 |
+-------------------------+------------------------------+

What can be the cause of my problem, can it be solved ?

Options: ReplyQuote


Subject Written By Posted
Windows: problem with unicode after update Mark Stam 12/15/2013 04:18AM
Re: Windows: problem with unicode after update Peter Brawley 12/15/2013 01:32PM
Re: Windows: problem with unicode after update Barry Galbraith 12/15/2013 02:58PM
Re: Windows: problem with unicode after update Mark Stam 12/16/2013 08:20AM
Re: Windows: problem with unicode after update Rick James 12/17/2013 05:08PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.