Skip navigation links

MySQL Forums :: PHP :: Error 2002 --> --without-mysql appears !?


Advanced Search

Error 2002 --> --without-mysql appears !?
Posted by: greg C ()
Date: March 27, 2006 09:33AM

Hi all,
I'm using a Webserver (apache + php5 + MySQL / Linux FC4) and i've a 2002 error Can't connect to local MySQL server through socket '/tmp/mysql.sock' (in phpMyAdmin for example)...

mysqld_safe is launched and >mysql works in command line. --> OK
The default path for the socket is set in the php.ini file. --> OK

I've checked phpinfo.php (phpinfo()) and there is "--without-mysql" in Configure Command section...

Everything used to work perfectly (i've installed php5 and so on with RPM) and I don't know why it has change to without-mysql.


How can i change it to --with-mysql ?

Thanks for answer.



Edited 2 time(s). Last edit at 03/27/2006 09:36AM by greg C.

Options: ReplyQuote


Subject Written By Posted
Error 2002 --> --without-mysql appears !? greg C 03/27/2006 09:33AM
Re: Error 2002 --> --without-mysql appears !? Kai Voigt 03/27/2006 07:35PM
Re: Error 2002 --> --without-mysql appears !? greg C 03/28/2006 01:24AM
SOLVED greg C 03/28/2006 02:16AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.