MySQL Forums
Forum List  »  Newbie

simple inserts that curiously fail
Posted by: Grace Lovely
Date: February 22, 2009 04:06PM

I start off with an empty table. Then I run a small python script that a) creates several columns and b) inserts some data into the table by using:
INSERT INTO table_a (column_a,column_b) VALUES ("abc","def")

For some reason the script works on one MySQL DB on a linux machine and doesn't on a MySQL DB on a Vista machine.

And now for the interesting part:
The columns ARE created. therefore the python script DOES reach the db. Even more curiously, the table I'm using has a self incrementing integer column, and when I tried to enter some data into the table manually, I discovered that the index given matches EXACTLY to the number of rows I tried to insert with the python script. I ran the python script several more times, of course nothing was added to the table, but adding a new row indeed showed the index advanced precisely, as if the data was inputted and discarded.

I'm a newbie, so if you need any info, please tell me how to get it. I'm using the latest MySQL distribution (downloaded on 22Feb/2009)

I'm not sure if this is relevant, but I'm using utf8 configuration. Tried both with strict mode and without, same results.

Options: ReplyQuote


Subject
Written By
Posted
simple inserts that curiously fail
February 22, 2009 04:06PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.