MySQL Forums
Forum List  »  Newbie

Re: root user cannot change system variables?
Posted by: Karl Jenkinson
Date: January 15, 2022 11:27AM

Again, thank you very much Peter. I really appreciate your quick responses!

As the root user, I tried:
ls -aR / | grep 'my*\.cnf'

I only got one hit but I have not figured out how to get the directory of the file! I am still looking for an answer. Google is my friend :)

Regarding the mysql error file, /var/log has no such error file. Maybe I do not recognize it? I tried to paste the listing, but:
"A word you have used in your post has been banned from use."

I did find an error log in /usr/local/mysql/data.

When I try to start the server, these lines are added:
2022-01-15T17:21:53.583893Z 0 [ERROR] [MY-000058] [Server] Unknown suffix '%' used for variable 'port' (value '%PORT%').
2022-01-15T17:21:53.583904Z 0 [ERROR] [MY-000077] [Server] /usr/local/mysql/bin/mysqld: Error while setting value '%PORT%' to 'port'.
2022-01-15T17:21:53.597734Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-01-15T17:21:53.597812Z 0 [Note] [MY-010120] [Server] Binlog end
2022-01-15T17:21:54.240114Z 0 [ERROR] [MY-000058] [Server] Unknown suffix '%' used for variable 'port' (value '%PORT%').
2022-01-15T17:21:54.240142Z 0 [ERROR] [MY-000077] [Server] /usr/local/mysql/bin/mysqld: Error while setting value '%PORT%' to 'port'.
2022-01-15T17:21:54.240319Z 0 [ERROR] [MY-010119] [Server] Aborting
2022-01-15T17:21:54.240392Z 0 [Note] [MY-010120] [Server] Binlog end


Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.