MySQL Forums
Forum List  »  Views

Re: strange utf8mb4 issue with views
Posted by: Jeff Stockett
Date: October 19, 2017 02:27PM

The CREATE VIEW command is executed via c# code using a normal MySQLConnection/MySQLCommand. I can look at it in Heidi/Workbench/or just plain old CLI afterward and see that it has been changed as described above with no action on my part. The part that is puzzling is when I do the ALTER VIEW in Heidi, the change back to what I had originally sticks and everything is happy. I tried changing the code to do both a CREATE VIEW and ALTER VIEW thinking that maybe CREATE VIEW had some "automagic" logic in it to normalize things - but that didn't work either (same problem). This leads me to the conclusion that Heidi must be setting a session variable or something that changes the behavior of CREATE VIEW and ALTER VIEW - my code based connection string does have "unicode=true" and my.cnf is setup correctly for utf8mb4 and everything works great with the database via code so I'm not sure what Heidi is doing but it must be doing something and I need to figure it out so I can do the same thing when the views get created via code because having to manually fix them each time I recreate that database is a pain.

Options: ReplyQuote


Subject
Views
Written By
Posted
1154
October 16, 2017 10:10AM
Re: strange utf8mb4 issue with views
525
October 19, 2017 02:27PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.