Re: default connection and client character set changing
Posted by: Takahiro Sasaki
Date: March 28, 2007 11:36AM

I'm also having problem setting character set.
You can set the my.cnf file with the following lines, which will set global variables to use all utf8. you can see mysql>show global variables or run mysqladim variables.

[client]
default-character-set=utf8
[mysql]
default-character-set=utf8
[mysqld_safe]
default-character-set=utf8
[mysqld]
default-character-set=utf8

However, I have a problem. The session (local) variables (can show by mysql>show varaibles) are not the same as global. The following is the session variables. Notice that some varaibles are set to utf8 correctly, leaving others latin1 (default).

character_set_client = latin1
character_set_connection = latin1
character_set_database = utf8
character_set_filesystem = binary
character_set_results = latin1
character_set_server = utf8
character_set_system = utf8
collation_connection = latin1_swedish_ci
collation_database = utf8_general_ci
collation_server = utf8_general_ci

Again, the my.cnf above sets global variables in the way I want.
I don't have any user specific .my.cnf file or anything like that. The version is 5.0.37 community edition (binary installation).

How can I get around with this? Is this a bug?

Taka.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: default connection and client character set changing
8202
March 28, 2007 11:36AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.