Re: cannot change character set
Posted by: Rick James
Date: June 26, 2010 01:30PM

I mentioned SHOW COLLATION because it also lists the possible charset.

phpmyadmin and the commandline tool (mysql) could well be defaulting differently.

Will ADO.NET let you do SET commands? If so, set the three session variables that comprise SET NAMES utf8.

Something is removing the accents. I believe it is either
* something other than mysql, or
* Mysql, but because of incorrect settings.

Possibly related (to Hungarian):,367170 (joined query problem),291431 (Slow retreieve under MyIsam),288177 (UTF-8 problem),287941 (trying to move a database from mysql 4.0.18 to 5.0.77),39066 (Server just hanging (Copying to tmp table))

It should be possible to put the 3 settings in my.cnf. (Sorry, I don't the exact syntax.)
shows 0xD5 0xF5 (iso upper/lower)
shows c590 / c591 (utf8) (or 0151)
details several representations

This says (to me) that the character is correctly represented in utf8 in the table:
Language3 HEX(Language3) LENGTH(Language3) CHAR_LENGTH(Language3)
ő C591 2 1

The 6f says that the character got converted going _into_ the table. Or it was de-accented even before handing to mysql.

I really wish I could say "do ___ to make your characters work right". But I keep running into situations that lead away from a simple answer. (Such as phpmyadmin vs commandline.)

Options: ReplyQuote

Written By
June 09, 2010 12:51PM
June 13, 2010 09:44PM
June 21, 2010 08:25AM
June 23, 2010 11:37PM
June 25, 2010 07:46AM
Re: cannot change character set
June 26, 2010 01:30PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.