Re: MYSQL doesn't 'see' accents
Posted by: Evi Wool
Date: June 26, 2010 03:34PM

Hi Peter, I've done some searches in Google so I'm guessing that you mean
Did I give any extra commands when I signed on.
Well I signed on with
Set Names 'utf8';
I then typed in
show variables like "%character%";
which got the results as follows:

| Variable_name | Value |
+--------------------------+----------------
| character_set_client | utf8 |
| character_set_connection | utf8 |
| character_set_database | latin1 |
| character_set_filesystem | binary |
| character_set_results | utf8 |
| character_set_server | latin1 |
| character_set_system | utf8 |

Since only one column in the database would contain accents (ironically, the one that contained English words), I modified that column to UTF8

SHOW CREATE TABLE TblEngTest;
and got this enlightening result:
| tblengtest | CREATE TABLE `tblengtest` (
`EngID` int(10) NOT NULL AUTO_INCREMENT,
`English` varchar(255) CHARACTER SET utf8 DEFAULT NULL,
PRIMARY KEY (`EngID`),
UNIQUE KEY `English` (`English`)
) ENGINE=MyISAM AUTO_INCREMENT=37711 DEFAULT CHARSET=latin1 |

I also tried signing in using 2 lines after the usual
cd \mysql\bin
mysql -u root

that is
Set names 'utf8';
set character set utf8;
but the second line seemed to undo the first one somehow and
SHOW VARIABLES indicated that the
character_set_connection was now back to Latin1

I suspect, after all that, the answer is that the database needed to have been created with UTF8.
I've got a horrible problem that while this will (or possibly only MAY) solve one problem, it may create others but I'm not sure about that. If that is so, I'd be better finding the problem rows in Access and then editing manually.

Options: ReplyQuote


Subject
Views
Written By
Posted
4429
June 23, 2010 05:31PM
1832
June 23, 2010 09:34PM
1969
June 24, 2010 12:00AM
2094
June 24, 2010 03:14AM
1896
June 24, 2010 05:59AM
1967
June 24, 2010 04:09PM
2673
June 26, 2010 06:12AM
2012
June 26, 2010 12:04PM
Re: MYSQL doesn't 'see' accents
2109
June 26, 2010 03:34PM
3876
June 26, 2010 06:46PM
1997
June 27, 2010 02:09AM
1963
June 27, 2010 12:48PM
2369
June 27, 2010 11:50PM
1854
June 28, 2010 12:13AM
1951
June 28, 2010 07:59PM
1802
June 28, 2010 09:27PM
2349
June 30, 2010 01:29AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.