Re: mysqldump re-encoding utf8 multi-byte characters - Why does latin1 solve the problem?
Posted by: Ely Peddler
Date: January 08, 2011 02:32PM

I have solved my problem although I'm not sure why it works.

I added the --character-sets-dir= option to the mysqldump call and it seems to now work.

Ignore the above I spoke too soon.

I was using more <dump-file> to view the file and it reported £ which I assumed meant it had worked, but on linux of course more uses utf8 so it was reporting 2 utf8 characters NOT 2 bytes representing 1 utf8 character.

However I may have fixed the issue now - I added --default-character-set=latin1 <- YES latin1 NOT utf8 and that seems to have fixed the problem.

Can anyone explain WHY this works? It is very counter intuitive.

mysqldump Ver 10.11 Distrib 5.0.77, for redhat-linux-gnu (i686)



Edited 3 time(s). Last edit at 01/09/2011 05:14AM by Ely Peddler.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: mysqldump re-encoding utf8 multi-byte characters - Why does latin1 solve the problem?
3123
January 08, 2011 02:32PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.