22001 Data too long for column
Posted by: Jaroslav Pilch
Date: October 30, 2005 11:16AM

I am trying to work with MySQL 5.0.15.

In file MY.INI:
[mysql]
default-character-set=cp1250
default-collation=cp1250_czech_cs
[mysqld]
default-character-set=cp1250
default-collation=cp1250_czech_cs

Variables:
character_set_client | cp1250
character_set_connection | cp1250
character_set_database | cp1250
character_set_results | cp1250
character_set_server | cp1250
character_set_system | utf8

collation_connection |cp1250_czech_cs
collation_database |cp1250_czech_cs
collation_server |cp1250_czech_cs

I create database and table:
CREATE TABLE k_nosic (
kod CHAR(5) NOT NULL,
popis VARCHAR(50) NOT NULL,
PRIMARY KEY (kod),
UNIQUE (popis)
);


I want to insert czech chars:
insert into k_nosic (kod, popis) values ('ab', 'ěščřžýáíé');

MySQL connection error: #22001Data too long for column 'popis' at row 1

I've got WindowsXP and I use MySQL Command Line Client.

Options: ReplyQuote


Subject
Views
Written By
Posted
22001 Data too long for column
25303
October 30, 2005 11:16AM
11695
November 09, 2005 05:55AM
9551
November 11, 2005 07:12AM
10013
December 02, 2005 09:50PM
7603
January 02, 2006 03:43PM
6482
March 14, 2006 09:34PM
6134
August 23, 2006 06:24AM
5848
August 17, 2007 07:08AM
5933
March 13, 2008 10:29AM
12313
November 12, 2005 05:29PM
6891
June 09, 2006 03:39AM
9056
July 21, 2006 07:21AM
9543
November 15, 2005 01:01AM
5888
August 18, 2006 10:32AM
13196
March 12, 2006 10:59AM
5478
March 14, 2006 11:34PM
5392
February 13, 2007 04:57AM
4567
February 13, 2007 05:18AM
5167
October 09, 2007 02:56AM
5281
December 03, 2007 11:02AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.