Special Characters in MySQL
Posted by: max
Date: November 10, 2005 04:54PM

Hi, I'm currently working on an Objective-C++ application that connects to a MySQL Database on the local machine. When the application attempts to submit special characters such as bullet points (pasted into my app from Microsoft Word) into VARCHAR and MEDIUMTEXT fields, they appear as '?'. I'm assuming that this has something to do with character sets. I've tried defaulting to the utf8 character set for each new database, table, and field that I create. I've also set all of the character_set_* variables to 'utf8' immediately after each connection from my app to MySQL is established. None of this has solved the problem. Are there other default character sets that I may need to change? Am I headed down the wrong path altogether with the character set thing? Any help that anyone could provide would be greatly appreciated.
-Max

Options: ReplyQuote


Subject
Views
Written By
Posted
Special Characters in MySQL
10101
max
November 10, 2005 04:54PM
3311
max
November 11, 2005 09:05AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.