blob data to infile
Posted by: Charles Kaminski
Date: April 27, 2017 12:07PM

I'm trying to take binary blob data and write it to an infile. I cannot get the data written to the file to match the data on the server. When I check the hex of both, they do not match.

I've read a number of posts across multiple sites and tried multiple things.

Things I've tried:
1. Setting the character set of the schema and table to binary
2. Select binary FieldName [..] into outfile FileName Character SET binary
3. Set character_set_client = binary;
4. Set character_set_connection = binary;
5. Set character_set_database = binary;
6. Set character_set_filesystem = binary;
7. Set character_set_result = binary;

Along with <<binary>>, I've tried a number of other charactersets. UTF8 gives me conversion errors as does a few others.

How do I output a binary blob to an infile and get the hex on the database to match the hex in the file?

Options: ReplyQuote

Written By
blob data to infile
April 27, 2017 12:07PM
April 27, 2017 12:13PM
April 28, 2017 02:53PM
May 04, 2017 10:53AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.