MySQL Forums
Forum List  »  Federated Storage Engine

Problem creating a federated table
Posted by: Jacek Szymanski
Date: May 25, 2013 02:24PM

Hi all,
I am trying to create a federated table. I am testing with a very simple table with only two fields. SHOW ENGINES shows that FEDERATED is enabled. I think I also have correct settings for the user which I am using for the user who connects because I am able to connect to the host database from the guest machine with -h option without problem.

Now the issue is that I CAN create the federated table and get no error. However, when I run a simple SELECT * from MYFEDERATEDTABLE; then the whole thing hangs and after a long while I get:
ERROR 1429 (HY000): Unable to connect to foreign data source: Can't connect to MySQL server on '196.168.2.231' (110).

The interesting thing is that there is NO entry in the transaction log on the host database when the federated table is created (if I understand some websites about federated tables right there should be something there). I also get no error when the federated table is created and to what I have been able to read, there should be something if my syntax is incorrect.

So, to sum up: I have the table on host, the federated table on gues, the user but can not get it to work.

What can be the reason?

Best regards

Jacek

Options: ReplyQuote


Subject
Views
Written By
Posted
Problem creating a federated table
3287
May 25, 2013 02:24PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.