MySQL Forums
Forum List  »  Federated Storage Engine

GTID based Replication with Federated tables
Posted by: Dhruvin Dharamsey
Date: July 13, 2021 10:17AM


I am trying to replicate the database which has few federated tables.

The replication is getting set but when I perform DML operations like Insert, Delete etc. The replication breaks.

Also when I perform DELETE operation on primary server the slave mysql crashes.

The federated table data is on remote server.

I also tried pointing the slave server to different remote server with same data as main remote server. This time the Insert statement ran succesfully without breaking the replication. But as soon as I ran DELETE command on federated table the MySQL on slave server got crashed.

Can someone suggest me where I am going wrong?

Dhruvin Dharamsey.

Options: ReplyQuote

Written By
GTID based Replication with Federated tables
July 13, 2021 10:17AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.