MySQL Forums
Forum List  »  MySQL Query Browser

I killed MySQL
Posted by: Gianna Bosanquet
Date: March 12, 2012 03:34AM

I was having a problem with MySQL that I suspect to be related to the 10.6.6 upgrade, and here's how I solved it. First, I copied all of my databases to a backup directory on my desktop:

+sudo cp -R /usr/local/old-mysql-directory /Users/sffc/Desktop+

Then, I downloaded and installed a fresh version of MySQL. I then copied all of my tables into the new directory (repeating the following command for all TableNames):

+sudo cp -R /Users/sffc/Desktop/old-mysql-directory/data/TableName /usr/local/new-mysql-directory/data+

Note that I used MyISAM on all of my tables; I'm not sure if InnoDB works in the same way.

I proceeded to start MySQL, but I still received the #2002 error. However, I was able to get MySQL functioning using the following command:

+sudo /usr/local/mysql/bin/mysqld -u root+

I'm not sure why that works when running something like "usr/local/mysql/bin/mysqladmin start" doesn't, but hey, it works!

To shut down MySQL, I run the following command in a new Terminal window:

+usr/local/mysql/bin/mysqladmin -u root -p shutdown+

I don't know if the auto-start on login works because I haven't restarted my computer since installing the updates.

Hopefully this post will help someone who faces a similar problem in the future.
Mid-2009 13-inch MacBook Pro, Mac OS X (10.6.6), 8GB RAM, 2.53 GHz Intel Core 2 Duo

Options: ReplyQuote

Written By
I killed MySQL
March 12, 2012 03:34AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.