MySQL Forums
Forum List  »  Install & Repo

Has anyone installed MySQL on SuSE 9.1 Pro?
Posted by: Phil Bolton
Date: October 01, 2004 08:33AM

I'm trying to get MySQL 4.0.18 to run in a SuSE 9.1 Pro environment on a Pentium 4 box. I am using the YaST package manager to do the installation. I run into two problems:
1. If I run mysqld_safe & as system root I get the message,"Starting mysqld daemon with databases from /var/lib/mysql 04100 10:10:57 mysqld ended

The log in /var/lib/mysql/mysqld.log shows:
041001 10:10:57 mysqld started
041001 10:10:57 Fatal error: Can't open privilege tables: Can't find file './mysql/host.frm' (errno: 13)
041001 10:10:57 Aborting
041001 10:10:57 /usr/sbin/mysqld: Shutdown complete

Yet, I see the host.frm file in /var/lib/mysql/mysql/host.frm as well as the columns_priv.*, db.*,func.*, tables_priv.* and user.* files

I've looked at the mysql_install_db script and I'm not that great at scripting but it looks like the $ldata variable is set correctly. I also looked at the /etc/my.cnf file and don't see anything that seems to be a problem, but I'm still learning scripting.

Can anyone assist?

Many thanks!

Options: ReplyQuote

Written By
Has anyone installed MySQL on SuSE 9.1 Pro?
October 01, 2004 08:33AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.