MySQL Forums
Forum List  »  Install & Repo

Re: Has anyone installed MySQL on SuSE 9.1 Pro?
Posted by: Arjen Lentz
Date: October 05, 2004 03:45PM

Phil Bolton wrote:
> I'm trying to get MySQL 4.0.18 to run in a SuSE 9.1 Pro environment on a Pentium 4 box. I am using
> the YaST package manager to do the installation. I run into two problems:
> 1. If I run mysqld_safe & as system root I get the message,"Starting mysqld daemon with databases
> from /var/lib/mysql 04100 10:10:57 mysqld ended

When installing the RPM, the MySQL server will start automatically (both straight away and on reboot).
If you want to stop/start the server, you can use /etc/init.d/mysql start (or stop), you should not need to ever run mysqld_safe directly.

> The log in /var/lib/mysql/mysqld.log shows:
> 041001 10:10:57 mysqld started
> 041001 10:10:57 Fatal error: Can't open privilege tables: Can't find file './mysql/host.frm' (errno: 13)

Error 13 is "Access Denied" (you can do "perror 13" in your shell to find out what an error means), so I have to conclude that the directory ownership is not set up properly. That's curious, as it should be automatically handled during installation of the RPM.

Try reinstalling, and if there's still a prob, please report on what owner/permissions the /var/lib/mysql directory has (just do an "ls -ld /var/lib/mysql").


Regards, Arjen.
Arjen Lentz, Exec.Director @ Open Query (
Remote expertise & maintenance for MySQL/MariaDB server environments.

Follow us at &

Options: ReplyQuote

Written By
Re: Has anyone installed MySQL on SuSE 9.1 Pro?
October 05, 2004 03:45PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.