MySQL Forums
Forum List  »  Install & Repo

Lost connection to MySql Server, system error 0
Posted by: Thomas Borge
Date: January 28, 2010 01:10AM


We have an mysql server on debian.
| Variable_name | Value |
| protocol_version | 10 |
| version | 5.0.51a-24+lenny1 |
| version_comment | (Debian) |
| version_compile_machine | i486 |
| version_compile_os | debian-linux-gnu |

We have configured it to allow remote connections,but it is here we have the problem.
When we tries to connect from remote, we get this error on linux clients
ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

and on windows clients we get this error
Connection Failed: [08S01][MySql][ODBC 5.1 Driver]Lost connection to MySql server at 'reading initial communication packet', system error: 2

We have set the bind-address to our servers address, we have inserted mysqld: ALL in hosts.allow
The firewall have been configured to allow connection remote.
We have granted users with the right access properties.

All the client has the newest mysql client, but we have also tried mysql -u root -h remoteip -p on the mysql server, and gets the same error then.

We have also tried earlier versions of mysql odbc on windows, but nothing have helped.

Have looked on everything i could find on google and this forum about it, but nothing seems to help.
Do you have any suggestion on what i can do?

Everything works just fine from localhost, just not from remote connection.

Kindly regards
Thomas Borge

Options: ReplyQuote

Written By
Lost connection to MySql Server, system error 0
January 28, 2010 01:10AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.