MySQL Forums
Forum List  »  Install & Repo

EASY FIX to Re: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Posted by: Marta N
Date: January 31, 2011 04:45AM

Easy Fix is to make sure that the user that you are connecting with have settings to access db from both ALL HOSTS (%) AND from LOCALHOST.
If you are using mysql Administrator to manage your DBs go to User Administration (link on left side) choose or create user that you want to connect with to db then right click on this user pick add host choose any host and ok (it should add @ % sign under user) then do the same but this time add localhost (this also will be indicated under your user) And at last the most important thing Apply Changes to this user so it will keep the settings.
As addition later you can play with privilages of your user by clicking on schema privileges tab and assigning additional privilages from available list.

Enjoy your administration
Marta

Options: ReplyQuote


Subject
Written By
Posted
June 27, 2009 08:29PM
EASY FIX to Re: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
January 31, 2011 04:45AM
December 16, 2007 02:18AM
December 27, 2007 02:08PM
January 16, 2011 06:51AM
August 27, 2009 12:22AM


Sorry, you can't reply to this topic. It has been closed.
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.