MySQL Forums
Forum List  »  Install & Repo

Re: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
Posted by: Shawn Tucker
Date: September 27, 2005 12:40PM

I had the same problem, this solution worked for me.

You will need to reset the password.

First start the mysql server instance or daemon with the --skip-grant-tables option. (security setting)

Then Execute these statements.
# mysql -u root mysql
mysql> UPDATE user SET Password=PASSWORD('your_new_password') where USER='root';

Finally, restart the instance/daemon without the --skip-grant-tables option.

You should be able to connect with your new password.

# mysql -u root -p
Enter password: your_new_password

Hope this helps.

Shawn Tucker

Options: ReplyQuote

Written By
June 27, 2009 08:29PM
Re: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
September 27, 2005 12:40PM
December 16, 2007 02:18AM
December 27, 2007 02:08PM
January 16, 2011 06:51AM
August 27, 2009 12:22AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.