MySQL Forums
Forum List  »  Install & Repo

Posted by: Eli Stone
Date: December 26, 2010 07:45PM

Well i got it working.

I shall explain how.

I found the fix here: (in the comments)
also here

But it took me a while to understand so i try to explain it easier.
Open Terminal and enter the following:

sudo nano /usr/local/mysql/support-files/mysql.server

This will open up the mysql.server file used to start up MySQL.
Then press ctrl + W to search for type in 'basedir=.' (with out the quotes)

Once you have found this line change it from:




Next search for 'mysqld_pid_file_path=$datadir/`hostname`.pid' (with out the quotes)

Again change it from:




Thats all the changes you need to make press ctrl + X and save the changes.
You might want to restart you computer for the effects to take places.

I then got a problem with MySQL not wanting to start up automatically but i fixed this here:

sudo chown -R root:wheel /Library/StartupItems/MySQLCOM
(although i cannot now turn it off but thats not such a big problem)

Hope this helps anyone out there with this problem. Sorry that it is a little long :P

Options: ReplyQuote

Written By
December 25, 2010 08:18AM
December 26, 2010 10:45AM
December 26, 2010 07:18PM
December 26, 2010 07:45PM
December 26, 2010 10:01PM
December 26, 2010 07:33PM
January 04, 2011 02:53PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.