MySQL Forums
Forum List  »  Install & Repo

mysqld ignores bind_address variable
Posted by: Arnaud OZOUKOU
Date: September 12, 2018 04:44PM

Hi,

I have downloaded mysql 8 binaries, untar files and then created a config file (mysql_test.cnf) with that content:
# ########################
[mysqld]
bind-address = 127.0.0.1
port = 8080
skip-networking = OFF
user = mysql
# ######################

Then i ran the mysqld with --initialize.

everything is fine.

but when i execute : sudo mysqld --defaults-file=mysql_test.cnf --user=mysql --skip-host-cache --bind-address=127.0.0.1

the Process starts and runs correctly, But for some reason it does not seem to be listening on 127.0.0.1:8080...
-> output of lsof -i:8080 is empty
-> log of mysqld shows: ready for connections. Version: '8.0.12' socket: '/tmp/mysql.sock' port: 8080 MySQL Community Server - GPL


i ran the command with sudo , as a non-root user.

Is there any specific context to force Mysql to listen to a particuler ip address ? i dont see what i am doing wrong here.

Options: ReplyQuote


Subject
Written By
Posted
mysqld ignores bind_address variable
September 12, 2018 04:44PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.