MySQL Forums
Forum List  »  Install & Repo

Re: Unable to install MySQL on macOS Catalina
Posted by: Paul Johnson
Date: October 14, 2020 09:34PM

My directory structure is different than yours. What I'm surmising is that an error log created by MySQL would provide useful information. I'm using "locate" to find files and directories containing mysql.

Anyway, I proceeded on a path related to an ownership issue:

I found this link:
https://stackoverflow.com/questions/41995912/macos-cant-start-mysql-server

On that page I found one post by Jack BeNimble suggesting the following ownership change:
sudo chown -R _mysql:wheel /usr/local/mysql/data

Being the gambler that I am, I tried it. (Changing group from _mysql to wheel)

Lo and behold, manually starting MySQL was successful using:
sudo /usr/local/mysql/support-files/mysql.server start

Elated, I moved back to the System Preferences for MySQL, and after happy feelings at seeing the two green dots (indicating success), I tried to stop MySQL by clicking on the button labelled "Stop MySQL Server". Sadly, it gave me the "legacyLoader wants to make changes" message (to which I responded by entering my system password). This didn't stop MySQL.

So... I tried manually stopping MySQL in Terminal with:
sudo /usr/local/mysql/support-files/mysql.server stop

It worked! And in the System Preferences for MySQL, the red dots showed MySQL was down.

Now the problem has been reduced to the getting the "Start/Stop MySQL Server" button to work.

Another ownership problem perhaps? Or maybe something more complicated because of changes in Catalina.

More fundamentally, why am I having these problems when I'm basically trying to do a vanilla install?

Options: ReplyQuote


Subject
Written By
Posted
Re: Unable to install MySQL on macOS Catalina
October 14, 2020 09:34PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.