MySQL Forums
Forum List  »  Install & Repo

mysql 5.7 service is not starting
Posted by: Gary K
Date: November 23, 2020 08:24AM

I have a windows server 2012 R2

I have MYSQL 5.7.30 installed

The security software lapsed due to a misconfiguration on cisco's website. So in order to stop the sql injection attacks I went into my.ini and uncommented the
skip networking line.

Cisco fixed the security software issue, so I went into my.ini and commented out the skip networking line.

I rebooted the server and the my sql service does not start. I went into the environmental variables and seen that the mysql path was set to 5.5 vice 5.7. I corrected that and ensure the path was correct and rebooted the server.

The service would not start. I have a copy of 5.7 on the server and tried a reinstall with no success. Mysql service hangs.

I decided to remove the service by sc delete mysql57 and it removed the service.

I made a copy of the Data files in a safe location

Is it possible to recover all of this without a complete reinstall? If a complete reinstall is necessary, can the data files be used to recover the databases?

I do nightly backups of the server, so that option is available, but if there is a quicker fix, I would appreciate any knowledge.

Thanks !

Options: ReplyQuote


Subject
Written By
Posted
mysql 5.7 service is not starting
November 23, 2020 08:24AM
November 23, 2020 08:40AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.