MySQL Forums
Forum List  »  Install & Repo

Re: Mysql5.7 - GPG KEY error
Posted by: Lance Rigdon
Date: January 19, 2022 08:32AM

Clive, I encountered the same issue. Apparently the GPG key for the MySQL 5.7 repo expired and you have to get a new one. I found this on a different site which may help.

https://forums.cpanel.net/threads/ups-421-mysql-5-7-36-5-7-37-upgrade-failed-due-to-gpg-keys-causing-upcp-rpmup-failure-warning-email.697217/

Basically The updated MySQL GPG will need to be installed. For existing systems, the MySQL repository file in /etc/yum.repos.d/ will need to have its 'gpgkey' line adjusted to:

gpgkey=https://repo.mysql.com/RPM-GPG-KEY-mysql-2022

For new installations you can import the key before running the installer:

rpm --import https://repo.mysql.com/RPM-GPG-KEY-mysql-2022

Good luck

Options: ReplyQuote


Subject
Written By
Posted
January 18, 2022 09:04AM
Re: Mysql5.7 - GPG KEY error
January 19, 2022 08:32AM
January 30, 2022 04:47AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.