MySQL Forums
Forum List  »  Install & Repo

New install, libmysql.dll issues
Posted by: Doug Munday
Date: July 23, 2022 12:47PM

I have mySQL80 server v8.0.27 64 bit Community Server running on a Windows 10 machine with a 32bit application. Everything is cool and works. Trying to set up new windows 10 machine as server. Basically trying to duplicate what I have. Tried first installing latest v8.0.29 server. I know I have to have libmysql.dll available for my app, so used the version that came with .29. When running the app and attempting to load the database, I get the dreaded error - libmysql.dll found, but could not be loaded.... Ok, so then copied the libmysql.dll from first server over to new server to app folder, still get the error. Then figured I can't upgrade MySQL without upgrading the Delphi app?
So deleted .29 server and workbench install and installed .27 server and workbench. Now that install is identical (as far as I know) to the one on my first server. Have identical libmysql.dll in app folder on new server as is on old server. Still get the error - "libmysql.dll found, but could not be loaded. Check compile-target and library compatibility." Everything is the same! What could be causing this issue? What is the compile-target? The application and how it was compiled? Or is it a 64bit vs 32bit issue?

Any help would be appreciated.

Options: ReplyQuote

Written By
New install, libmysql.dll issues
July 23, 2022 12:47PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.