MySQL Forums
Forum List  »  Install & Repo

How to make MySQL obey connect_timeout setting config file?
Posted by: Mike Levin
Date: October 06, 2022 03:07AM

I'm running MySQL (mysql-5.6.26-osx10.8-x86_64) on a Mac 10.14 system. Everything works fine, except I get a lot of timeouts when using MailSteward Pro client to archive email to a database. So I was told to increase the timeout setting in /usr/local/mysql/my.cnf

By default, the server was showing this:

$ ./bin/mysqladmin -u root -p variables | grep timeout Enter password: | connect_timeout | 864

so a timeout of 864. I then edited the config file to add this:

wait_timeout = 86400
connect_timeout = 86400

and restarted, but then the server reported

$ ./bin/mysqladmin -u root -p variables | grep timeout Enter password: | connect_timeout | 10

so it's gone from 864 to 10, when I tried to send it to 86400 (made it worse). What am I doing wrong, and what do I do to make it accept a much larger timeout value?

Options: ReplyQuote


Subject
Written By
Posted
How to make MySQL obey connect_timeout setting config file?
October 06, 2022 03:07AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.