MySQL Forums
Forum List  »  Install & Repo

Re: can't connect to MySql server on 'localhost' <10061>
Posted by: Sergi Kirchner
Date: June 26, 2007 08:46AM

I had the same problem: "can't connect to MySql server on 'localhost'" on a OpenCms (content manager) installation (following OpenCms install instructions).

I passed over the problem using \mysql\bin\mysqld --skip-grant-tables option, and I got the OpenCms runnig. But it was not fixed cause with this option every user has access to all the tables.

If I used \mysql\bin\mysqld without any parameter y had the famous: "can't connect to MySql server on 'localhost' <10061>" problem.

I had changed the root user password to 'whatever' but when I replaced to '' AGAIN (connecting to database using the --skip-grant-tables parameter) I got all runnig Ok.

Now I have the no-password user root problem but for me it's ok.

Options: ReplyQuote


Subject
Written By
Posted
March 16, 2010 11:16PM
June 12, 2009 01:06PM
July 25, 2005 08:47AM
January 20, 2006 11:38AM
April 09, 2010 05:07PM
December 09, 2007 06:57AM
Re: can't connect to MySql server on 'localhost' <10061>
June 26, 2007 08:46AM
January 13, 2010 03:53AM
June 25, 2009 05:58AM
July 15, 2009 02:19PM
July 15, 2009 06:01PM
October 07, 2009 09:41AM
March 14, 2011 06:28AM
December 03, 2009 03:00AM
December 14, 2009 01:14PM
January 04, 2010 03:49AM
March 20, 2010 07:52AM
March 16, 2010 11:08PM
May 10, 2010 06:56PM


Sorry, you can't reply to this topic. It has been closed.
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.