MySQL Forums
Forum List  »  Install & Repo

Re: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
Posted by: Chris siefken
Date: March 28, 2005 04:01PM

I have the same problem and I have tried all of your suggestions even the one CC posted that has you create a new cnf flile I have as of yet it seems been able to start up MySQL successfully.

the error reads as the title of these posts read. I do not have the socket file in place. I believe its a result of not having been capable of getting the server started. When I run...

# service mysql start

I get no returned value. I have tried the permssions and creating a cnf file any help would be nice... I really need to figure this out to move on to PHP 5. thankfully I started this transition on a test box or I would be upset.

I have also tried.

"whereis" finds both a mysql and an mysqld.

I am also running gnome and the gui says the service starts normally but everything points to it no actually being started.

system details:
RedHat Fedura Core 3
MySQL 3.XXX un installed
Supporting libraries for MySQL 3.XXX Un installed.

more or less the standard system config from there.
128 Mb RAM
1.2 ghz AMD something
(painfully slow but its not my production machine.)

Thanks in advance.

Options: ReplyQuote

Written By
Re: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
March 28, 2005 04:01PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.