MySQL Forums
Forum List  »  Ruby

Problem installing mysql gem on CentOS 5.4 with ruby-enterprise
Posted by: Stefan Stefansson
Date: January 22, 2010 10:07AM


I have installed the ruby-enterprise and ruby-enterprise-rubygems packages from on a fresh CentOS 5.4 box (x86_64).

I need to install the mysql gem but I'm getting an error message that it can't find mysql.h.

After googling I found two suggestions:

1) Install mysql-devel. This was already done so this solution didn't work for me.
2) Install using "gem install mysql -- --with-mysql-config=/usr/lib64/mysql/mysql_config". I tried this but I get the exact same error message.

The error I'm getting is the following:
[root@projects ~]# gem install mysql -- --with-mysql-config=/usr/lib64/mysql/mysql_config
Building native extensions. This could take a while...
ERROR: Error installing mysql:
ERROR: Failed to build gem native extension.

/usr/local/bin/ruby extconf.rb --with-mysql-config=/usr/lib64/mysql/mysql_config
checking for mysql_ssl_set()... no
checking for rb_str_set_len()... no
checking for rb_thread_start_timer()... no
checking for mysql.h... no
checking for mysql/mysql.h... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:

Gem files will remain installed in /usr/local/lib/ruby/gems/1.8/gems/mysql-2.8.1 for inspection.
Results logged to /usr/local/lib/ruby/gems/1.8/gems/mysql-2.8.1/ext/mysql_api/gem_make.out

I would appreciate any and all help resolving this. I'm not familiar with ruby/gem so any pointers on how to get more debugging information out of this could help quite a lot.

Kind regards, Stefan Freyr.

Options: ReplyQuote

Written By
Problem installing mysql gem on CentOS 5.4 with ruby-enterprise
January 22, 2010 10:07AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.