MySQL Forums
Forum List  »  Source, Builds, Binaries

Compiling 5.5.31 from source using Cygwin
Posted by: NOT_FOUND NOT_FOUND
Date: June 21, 2013 06:25PM

I have compiled MySQL multiple times with no problem on Windows using CygWin. Now it seems there is a problem. I have tried several different versions of MySQL and they all end at the same place.

When I install CygWin it loads a set of default packages and Then I add the other packages I need to finish compiling MySQL.

I can do a “make mysqlclient” and that completes with no errors.

When I do a “make install” I get this error and the compiling stops.

[ 96%] Building C object extra/CMakeFiles/perror.dir/perror.c.o
Linking C executable perror.exe
[ 96%] Built target perror
Scanning dependencies of target replace
[ 96%] Building C object extra/CMakeFiles/replace.dir/replace.c.o
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c: In function `internal_set_bit':
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c:754: error: `__SIZEOF_INT__' undeclared (first use in this function)
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c:754: error: (Each undeclared identifier is reported only once
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c:754: error: for each function it appears in.)
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c: In function `internal_clear_bit':
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c:760: error: `__SIZEOF_INT__' undeclared (first use in this function)
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c: In function `get_next_bit':
/cygdrive/d/cygwin/mysql-5.5.31/extra/replace.c:792: error: `__SIZEOF_INT__' undeclared (first use in this function)
extra/CMakeFiles/replace.dir/build.make:57: recipe for target `extra/CMakeFiles/replace.dir/replace.c.o' failed
make[2]: *** [extra/CMakeFiles/replace.dir/replace.c.o] Error 1
CMakeFiles/Makefile2:2792: recipe for target `extra/CMakeFiles/replace.dir/all' failed
make[1]: *** [extra/CMakeFiles/replace.dir/all] Error 2
Makefile:146: recipe for target `all' failed
make: *** [all] Error 2

Michael@Morpheus /cygdrive/d/cygwin/mysql-5.5.31

I went back several version of MySQL and it does the same thing. So I’m assuming there is a problem with one of the packages. I did try using several other mirrors to pull packages, but the same result.

Options: ReplyQuote


Subject
Views
Written By
Posted
Compiling 5.5.31 from source using Cygwin
3692
June 21, 2013 06:25PM


Sorry, you can't reply to this topic. It has been closed.
This forum is currently read only. You can not log in or make any changes. This is a temporary situation.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.