MySQL Forums
Forum List  »  Source, Builds, Binaries

MySQL v8.0: Unable to run mysql binary
Posted by: Ashwin Reddy
Date: August 18, 2020 11:15PM

I have newly upgraded our mysql from v5.7 to v8.0.21.
Upgradation was success. Since we our installation is binary type I need to update new v8.0 binaries to /usr/bin. After doing so, when I run below command to check mysql version/login to mysql. I am getting following error.

mysql --version
mysql: error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory

Note: I am able login and check version info. when I run the command from basedir.
./mysql --version

OS: CentOS Linux release 7.3.1611 (Core)

Installed packages: libaio-0.3.109-13.el7.x86_64

ll /usr/lib64/libssl*
/usr/lib64/libssl3.so
/usr/lib64/libssl.so -> libssl.so.1.0.2k
/usr/lib64/libssl.so.10 -> libssl.so.1.0.2k
/usr/lib64/libssl.so.1.0.2k

Can anyone please let me know what could be the issue in my case.

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL v8.0: Unable to run mysql binary
310
August 18, 2020 11:15PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.