MySQL Forums
Forum List  »  Source, Builds, Binaries

Re: MySQL v8.0: Unable to run MySQL binary
Posted by: Bjørn Munch
Date: September 22, 2022 01:51AM

First, 8.0.21 is nine releases and over two years old, I recommend using the newest version 8.0.30 if you're upgrading anyway.

You did not mention what MySQL package you installed, but I see mysql is linked with OpenSSL 1.1.1 and not with system OpenSSL 1.0.2. So this would be either the generic tarball or the el7 tarball.

Both packages includes a bundled OpenSSL 1.1.1 library but in order for mysql to find it, it needs to be installed in ../lib/private relative to the mysql binary. So if mysql is in /usr/bin, the bundled library needs to be in /usr/lib/private. This is also the case for the other libraries in lib/private in the MySQL tarball.

I assume you unpacked the 8.0.21 package somewhere and then moved the binaries to /usr/bin, but for 8.0 that is not enough. You also need those libraries. This is not needed for 5.7 since that links OpenSSL statically into the mysql binary.

Options: ReplyQuote


Subject
Views
Written By
Posted
396
September 21, 2022 11:31PM
Re: MySQL v8.0: Unable to run MySQL binary
205
September 22, 2022 01:51AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.