MySQL Forums
Forum List  »  Italian

Problema connessione DB su MacOs+MAMP
Posted by: Fulvio Varone
Date: January 13, 2021 10:33AM

Salve a tutti,
sono nuovo e direi anche piuttosto inesperto, dal momento che la programmazione è per me essenzialmente un hobby.

Ho un problema che mi è uscito giusto questa mattina dopo aver aggiornato il s.o. da MacOs 10.9 al 10.13, aggiornamento che mi ha mandato in palla tutto il server web che avevo installato (Apple vuole vendere il suo pacchetto, per cui mette un po' i bastoni tra le ruote a chi "si arrangia").
Dopo essere riuscito a ripristinare il server usando il pacchetto MAMP, ora mi ritrovo con le pagine php che si collegano regolarmente ai database (che ho spostato dalla loro vecchia posizione alla nuova previsa da Mamp), senza alcun errore, ma "vedono" le tabelle vuote, come se non ci fossero dati al loro interno, mentre so per certo che sono piene (e lo si desume anche dalla dimensione dei files sul disco).
Per fare un esempio, in uno script che serve ad inserire nuovi record in una tabella, normalmente dovrebbe visualizzare il primo numero progressivo disponibile, ma esce il numero "1", come se ciò che si va ad inserire fosse il primo.
Problemi col socket? Con i permessi?
Dove ho sbagliato?

Grazie e scusate per le imprecisioni nel mio modo di esprimermi...

Options: ReplyQuote


Subject
Views
Written By
Posted
Problema connessione DB su MacOs+MAMP
71
January 13, 2021 10:33AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.