MySQL Forums
Forum List  »  Quality Assurance

Losing data records
Posted by: Guillermo Sobalvarro
Date: September 17, 2007 01:56PM

Am losing records on a large myISAM table that has close to 1.2 million records.

Working off of a Dell 1950 server with 2GB RAM and a CORE 2 DUO 3GHZ. Running FreeBSD 6.2 (not configured for MP yet) and MySQL 5.0.27-log.

my.cnf is configured from the sample my.huge.cnf.

Raid reports no errors:

mfid0: <MFI Logical Disk> on mfi0
mfid0: 278784MB (570949632 sectors) RAID volume 'Whatever' is optimal

Have plenty of space on all filesystems.

The same PHP program that had been running for the past 4 years on older IBM hardware with no RAID operated correctly and never lost data. Since moving to the Dell problem has shown up. The PHP program reports no errors and has no script that does a DELETE on the database an the specific table from where records are disappearing so the program is not causing deletion of records directly. No other user has access apart from the app.

Any ideas on how to catch this error and possibly fix the problem?

Tks.



Edited 1 time(s). Last edit at 09/19/2007 08:41AM by Guillermo Sobalvarro.

Options: ReplyQuote


Subject
Views
Written By
Posted
Losing data records
4852
September 17, 2007 01:56PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.