MySQL Forums
Forum List  »  Quality Assurance

MySQL Port closed
Posted by: Igor Petrakov
Date: January 08, 2008 08:25AM

MySQL version 5.0.45


I am trying to connect to the mysql process from the computer that it's running on and I can't.


I have two identical quad-core 64 bit redhat boxes. One of them has MySQL installed.

Initially, I only had one box and was connecting to the mysql database without a problem. Then I needed to use mysql with networking to i went in and changed the /etc/my.cnf file, here's what's there now:

Quote
/etc/my.cnf
# Example MySQL config file for medium systems.
#
# This is for a system with little memory (32M - 64M) where MySQL plays
# an important part, or systems up to 128M where MySQL is used together with
# other programs (such as a web server)
#
# You can copy this file to
# /etc/my.cnf to set global options,
# mysql-data-dir/my.cnf to set server-specific options (in this
# installation this directory is /var/lib/mysql) or
# ~/.my.cnf to set user-specific options.
#
# In this file, you can use all long options that a program supports.
# If you want to know which options a program supports, run the program
# with the "--help" option.

# The following options will be passed to all MySQL clients
[client]
#password = your_password
port = 3306
socket = /var/lib/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
### basedir & datadir variable added by EDM 080607
### trying to correct the following mysqld startup error
### Fatal error: Can't open and lock privilege tables: Table 'mysql.host' doesn't exist
[mysqld]
port = 3306
socket = /var/lib/mysql/mysql.sock
basedir = /var/lib/mysql
datadir = /var/lib/mysql/data
skip-locking
key_buffer = 16M
max_allowed_packet = 1M
table_cache = 64
sort_buffer_size = 512K
net_buffer_length = 8K
read_buffer_size = 256K
read_rnd_buffer_size = 512K
myisam_sort_buffer_size = 8M
bind-address = 166.22.66.81

# Don't listen on a TCP/IP port at all. This can be a security enhancement,
# if all processes that need to connect to mysqld run on the same host.
# All interaction with mysqld must be made via Unix sockets or named pipes.
# Note that using this option without enabling named pipes on Windows
# (via the "enable-named-pipe" option) will render mysqld useless!
#
#skip-networking

# Replication Master Server (default)
# binary logging is required for replication
log-bin=mysql-bin

# required unique id between 1 and 2^32 - 1
# defaults to 1 if master-host is not set
# but will not function as a master if omitted
server-id = 1

# Replication Slave (comment out master section to use this)
#
# To configure this host as a replication slave, you can choose between
# two methods :
#
# 1) Use the CHANGE MASTER TO command (fully described in our manual) -
# the syntax is:
#
# CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
# MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
#
# where you replace <host>, <user>, <password> by quoted strings and
# <port> by the master's port number (3306 by default).
#
# Example:
#
# CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
# MASTER_USER='joe', MASTER_PASSWORD='secret';
#
# OR
#
# 2) Set the variables below. However, in case you choose this method, then
# start replication for the first time (even unsuccessfully, for example
# if you mistyped the password in master-password and the slave fails to
# connect), the slave will create a master.info file, and any later
# change in this file to the variables' values below will be ignored and
# overridden by the content of the master.info file, unless you shutdown
# the slave server, delete master.info and restart the slaver server.
# For that reason, you may want to leave the lines below untouched
# (commented) and instead use CHANGE MASTER TO (see above)
#
# required unique id between 2 and 2^32 - 1
# (and different from the master)
# defaults to 2 if master-host is set
# but will not function as a slave if omitted
#server-id = 2
#
# The replication master for this slave - required
#master-host = <hostname>
#
# The username the slave will use for authentication when connecting
# to the master - required
#master-user = <username>
#
# The password the slave will authenticate with when connecting to
# the master - required
#master-password = <password>
#
# The port the master is listening on.
# optional - defaults to 3306
#master-port = <port>
#
# binary logging - not required for slaves, but recommended
#log-bin=mysql-bin

# Point the following paths to different dedicated disks
#tmpdir = /tmp/
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = /var/lib/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = /var/lib/mysql/
#innodb_log_arch_dir = /var/lib/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#innodb_buffer_pool_size = 16M
#innodb_additional_mem_pool_size = 2M
# Set .._log_file_size to 25 % of buffer pool size
#innodb_log_file_size = 5M
#innodb_log_buffer_size = 8M
#innodb_flush_log_at_trx_commit = 1
#innodb_lock_wait_timeout = 50

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[myisamchk]
key_buffer = 20M
sort_buffer_size = 20M
read_buffer = 2M
write_buffer = 2M

[mysqlhotcopy]
interactive-timeout

Now, I can successfully connect to MySQL from the other linux box but not from the localhost. (Yes, i use 127.0.0.1 instead of localhost).

In fact, when I telnet from the remote machine to port 3306, i get weird characters as well as the mysql version. When I telnet from the local machine, it says connection refused.

When I do a "nmap -p 3306 localhost" it responds with this line:
3306/tcp closed mysql


I'm really confused since my remote box has been able to successfully insert data into the database.

Other notes:
1.I have moved the hosts.deny file so it is no longer there.
2.Here's my hosts.allow file:
Quote
hosts.allow
#
# hosts.allow This file describes the names of the hosts which are
# allowed to use the local INET services, as decided
# by the '/usr/sbin/tcpd' server.
#

### the following control added by EDM on 120706 (copied from charleston)
### in.rshd,in.rlogind,in.rexecd,fingerd, removed by EDM on 120706 (now matches proliant2)
ftpd,telnetd,sshd,mysqld,mysqld_safe: LOCAL: spawn (/bin/echo "`/bin/date` `hostname` allowed access %d %u %n %a" >> /var/log/wrapper.log)
ALL : 127.0.0.1
3.Yes, inside the mysql command-line client (which i accessed from the local box), i put in the settings GRANT ALL ON db_name.* TO root@127.0.0.1 IDENTIFIED BY 'password'
4.When I telnet remotely, I can see the mysql version and funny characters
5.When I telnet locally, says connection refused.


Help please! (Or tell me what additional data I need to post).

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL Port closed
29293
January 08, 2008 08:25AM
5066
January 21, 2008 05:32PM
6019
January 30, 2008 08:46AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.