MySQL Forums
Forum List  »  Quality Assurance

Mysql not starting - problem with hard drive
Posted by: Ricardo Freitas
Date: July 15, 2012 12:39PM

Hello everyone

I have a replication set up with two databases, a master-master system.

I consider one of them the "main" master where every single insert query is made into.

The problem is I had the slave-bin on this main database to be saved into a hard drive that suddenly crashed and stop working.

From that point on, I couldn't insert anything into the main database nor stop, start or do any slave queries related.

I tried to stop the mysql server and it failed. From this point on I can't connect to mysql (mysql.sock related problem) and I can't restart eh mysql, stop, start, nothing - I keep getting failed.

I've watching the mysqld.log and nothing is reported there (once the stop failed).

I even tried to stop the process in the system (centos) and the process just don't die - I'm guessing there is some kind of input/output suspension regarding the disk going corrupt.

What can I do regarding this?

Any tips?



Options: ReplyQuote

Written By
Mysql not starting - problem with hard drive
July 15, 2012 12:39PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.