MySQL Forums
Forum List  »  Router & Proxy

Problem installing 0.8.0 on Debian Lenny [resolved]
Posted by: Gurvan Kervern
Date: March 08, 2010 02:50AM

Hello,

I have tried to install (or just run) MySQL Proxy 0.8.0 on a server lately but I can't seem to get it right :

I followed the instructions concerning the dependencies in the README and INSTALL but I always got at some point :
"configure: error: event_base_new() wasn't found in libevent. we need at least libevent 1.4"
(although libevent1, libevent-dev and libevent1-4.2 were installed)
So I removed libevent1 so it would look in libevent1-4.2 but then got :
"checking for event_init in -levent... no
configure: error: libevent is required"
I had the same issues with the version from the Bazar.

I tried to run from the binary distribution so I could play around with it and try some Lua scripts, but it seems like mysql-proxy doesn't use my --defaults-file and when I try to connect to it, I get :
"ERROR 1105 (00000): #07000(proxy) all backends are down"
even though both servers are up and running...

I had exactly the same problems with 0.7.2 but for some reason, it got to the end of ./configure and make this morning, so it appears I could do a "make install" of this version. But I would really rather use 0.8.0.

I have also tried the repository version of the package, but it was mysql-proxy0.6.0; and a .deb paquet of 0.7.2 but ran into the same dependencies problem I had with the source version.

Any insight into this problem would be much appreciated.

Gurvan



Edited 1 time(s). Last edit at 03/11/2010 01:39AM by Gurvan Kervern.

Options: ReplyQuote


Subject
Views
Written By
Posted
Problem installing 0.8.0 on Debian Lenny [resolved]
5295
March 08, 2010 02:50AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.