MySQL Forums
Forum List  »  memcached

ConcurrentModificationException using spymemcached with spring integration
Posted by: michal singer
Date: July 10, 2012 01:07AM

hi, I use mecached and java spymemcached client version2.8.1
when i use the spymemcached integerated with Spring
I get:
in the AbstractLog:
at java.util.HashMap$HashIterator.nextEntry(
at java.util.HashMap$
at net.spy.memcached.util.StringUtils.join(
at net.spy.memcached.protocol.ascii.BaseGetOpImpl.toString(
at java.lang.String.valueOf(
at java.lang.StringBuilder.append(
at net.spy.memcached.protocol.TCPMemcachedNodeImpl.toString(
at java.util.Formatter$FormatSpecifier.printString(
at java.util.Formatter$FormatSpecifier.print(
at java.util.Formatter.format(
at java.util.Formatter.format(
at java.lang.String.format(
at net.spy.memcached.compat.log.AbstractLogger.debug(

I checked this using spymemcached without spring integration and it worked fine.
I used the same code the spring wrapper for MemcachedClient uses and it worked.
Any ideas whyt this happends, are there any known issues with this integeration?

Options: ReplyQuote

Written By
ConcurrentModificationException using spymemcached with spring integration
July 10, 2012 01:07AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.