MySQL Forums
Forum List  »  MySQL Workbench

charset problem with SQL Server
Posted by: Joe Murray
Date: December 10, 2018 01:17PM

On reverse engineer schema I get:
Error: UnicodeDecodeError: 'utf16' codec can't decode byte 0x65 in position 22: truncated data

I have a newly installed WIN10, SQL Server 2017, with a restored recent database backup from Raisers Edge in an old format. The Collation of the database is SQL_Latin1_General_CP1_CI_AS. I believe this indicates:
charset latin 1
CP1 stands for Code Page 1252
CI case insensitive comparisons
AS accent sensitive

There are strings with accents, as well as image and other binary data in the db. I am not sure why 0x65 causes error since I was under the impression it is just a small e in utf16 like in utf8 and ucs2.

I have installed MySQL 8.0.13 and MySQL 8.0.13 with installer. SHOW CREATE DATABASE aore_new; yields result
'aore_new', 'CREATE DATABASE `aore_new` /*!40100 DEFAULT CHARACTER SET utf8mb4 COLLATE utf8mb4_0900_ai_ci */'


Using ODBC Administrator I tried three driver options for configuring a System DSN:
- ODBC Driver 13 for SQL Server (Version 2017.140.2002.14)
- SQL Server (Version 10.00.17763.01) and
- SQL Server Native Client 11.0 (version 2011.110.6540.00).

I tried varying the option Perform translation for character data with no change in the result.

How should I configure a things in order to migrate data into MySQL from SQL Server.

Options: ReplyQuote


Subject
Views
Written By
Posted
charset problem with SQL Server
114
December 10, 2018 01:17PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.