MySQL Forums
Forum List  »  MySQL Workbench

Table Data Export Wizard fails after upgrades
Posted by: Michael Homa
Date: March 21, 2022 07:52AM

The Table Data Export Wizard fails with the following log errors:

Traceback (most recent call last):
File "/Applications/MySQLWorkbench.app/Contents/Resources/libraries/workbench/wizard_progress_page_widget.py", line 197, in thread_work
self.func()
File "/Applications/MySQLWorkbench.app/Contents/Resources/plugins/sqlide_power_export_wizard.py", line 273, in start_export
retval = self.module.start(self.stop)
File "/Applications/MySQLWorkbench.app/Contents/Resources/plugins/sqlide_power_import_export_be.py", line 302, in start
ret = self.start_export()
File "/Applications/MySQLWorkbench.app/Contents/Resources/plugins/sqlide_power_import_export_be.py", line 398, in start_export
output.writerow(row)
UnicodeEncodeError: 'ascii' codec can't encode character '\xbd' in position 12: ordinal not in range(128)
ERROR: Export data to file: 'ascii' codec can't encode character '\xbd' in position 12: ordinal not in range(128)
Failed

I believe these errors were the result of table data that included single quotes in text columns and vulgar fractions like ½. These fractions display correctly in Workbench, and cause no problems in queries or views, and I can create dump files without issue.
I recently upgraded MySQL and Workbench to 8.0.28. During that upgrade I lost the schema involved and had to restore it from a dump file I had previously created with Workbench 8.0.22 and MySQL Community Edition 8.0.23.
Prior to the MySQL upgrade I had converted my iMac to macOS Monterey. After the macOS upgrade, MySQL server and Workbench restarted and operated without issue, but I did not use the Table Data Export Wizard until after I upgraded MySQL and Workbench.
I am using an iMac 27”, 2017, macOS Monterey 12.2.1, 3.8 GHz Quad-Core Intel i5.

I can successfully export table data without using the wizard, by simply executing a query to output all records and then use the export recordset button on the table result panel. The exported csv file includes the problematic vulgar fraction (common fraction).
I have tested the Table Data Export Wizard using a simple table without any "special" characters, and the wizard worked OK.
I have not knowingly changed character sets (and wouldn't know how to do it if I tried). I'm new to MySQL so any advice would be appreciated.

Options: ReplyQuote


Subject
Views
Written By
Posted
Table Data Export Wizard fails after upgrades
299
March 21, 2022 07:52AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.